关于IT运维技术的
最佳实践博客网站

记一次 Command “python setup.py egg_info” failed with error

错误提示:

[root@c7 ~]# pip install pillow moviepy
Looking in indexes: https://mirrors.aliyun.com/pypi/simple/
Requirement already satisfied: pillow in /usr/lib64/python2.7/site-packages (2.0.0)
Collecting moviepy
  Downloading https://mirrors.aliyun.com/pypi/packages/1f/af/98b68b047c47d9430cb4c9ac899cf9d969de3936f888072991ea74da93a8/moviepy-0.2.3.5.tar.gz (372kB)
    100% |████████████████████████████████| 378kB 11.0MB/s
    Complete output from command python setup.py egg_info:
    error in moviepy setup command: 'extras_require' must be a dictionary whose values are strings or lists of strings containing valid project/version requirement specifiers.

    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-install-m_uprt/moviepy/

解决方法

[root@c7 ~]# pip install --upgrade setuptools
Looking in indexes: https://mirrors.aliyun.com/pypi/simple/
Collecting setuptools
  Downloading https://mirrors.aliyun.com/pypi/packages/66/e8/570bb5ca88a8bcd2a1db9c6246bb66615750663ffaaeada95b04ffe74e12/setuptools-40.2.0-py2.py3-none-any.whl (568kB)
    100% |████████████████████████████████| 573kB 11.3MB/s
Installing collected packages: setuptools
  Found existing installation: setuptools 0.9.8
    Uninstalling setuptools-0.9.8:
      Successfully uninstalled setuptools-0.9.8
Successfully installed setuptools-40.2.0
[root@c7 ~]# pip install pillow moviepy
Looking in indexes: https://mirrors.aliyun.com/pypi/simple/
Requirement already satisfied: pillow in /usr/lib64/python2.7/site-packages (2.0.0)
Collecting moviepy
  Downloading https://mirrors.aliyun.com/pypi/packages/1f/af/98b68b047c47d9430cb4c9ac899cf9d969de3936f888072991ea74da93a8/moviepy-0.2.3.5.tar.gz (372kB)
    100% |████████████████████████████████| 378kB 9.0MB/s
Collecting decorator<5.0,>=4.0.2 (from moviepy)
  Downloading https://mirrors.aliyun.com/pypi/packages/bc/bb/a24838832ba35baf52f32ab1a49b906b5f82fb7c76b2f6a7e35e140bac30/decorator-4.3.0-py2.py3-none-any.whl
Collecting imageio<3.0,>=2.1.2 (from moviepy)
  Downloading https://mirrors.aliyun.com/pypi/packages/a7/1d/33c8686072148b3b0fcc12a2e0857dd8316b8ae20a0fa66c8d6a6d01c05c/imageio-2.3.0-py2.py3-none-any.whl (3.3MB)
    100% |████████████████████████████████| 3.3MB 8.3MB/s
Collecting tqdm<5.0,>=4.11.2 (from moviepy)
  Downloading https://mirrors.aliyun.com/pypi/packages/c7/e0/52b2faaef4fd87f86eb8a8f1afa2cd6eb11146822033e29c04ac48ada32c/tqdm-4.25.0-py2.py3-none-any.whl (43kB)
    100% |████████████████████████████████| 51kB 11.9MB/s
Collecting numpy (from moviepy)
  Downloading https://mirrors.aliyun.com/pypi/packages/c9/16/1134977cc35d2f72dbe80efa75a8e989ac21289f8e7e2c9005444cd17cd5/numpy-1.15.1-cp27-cp27mu-manylinux1_x86_64.whl (13.8MB)
    100% |████████████████████████████████| 13.8MB 14.4MB/s
Installing collected packages: decorator, numpy, imageio, tqdm, moviepy
  Found existing installation: decorator 3.4.0
    Uninstalling decorator-3.4.0:
      Successfully uninstalled decorator-3.4.0
  Running setup.py install for moviepy ... done
Successfully installed decorator-4.3.0 imageio-2.3.0 moviepy-0.2.3.5 numpy-1.15.1 tqdm-4.25.0
赞(0)
未经允许不得转载:菜鸟HOW站长 » 记一次 Command “python setup.py egg_info” failed with error
分享到: 更多 (0)

留下你的脚印

  订阅  
关注动态